0

I use my Pi model B1 as a wifi repeater (with two wireless dongles).

I'm using hostapd and dnsmasq.

My settings are:

/etc/dhcpcd.conf

interface wlan0
static ip_address=192.168.42.1/24
nohook wpa_supplicant

/etc/dnsmasq.conf

interface=wlan0
dhcp-range=192.168.42.20,192.168.42.100,255.255.255.0,12h

hostapd is very unstable so I want to run my access point with wpa_supplicant

I added /etc/wpa_supplicant/wpa_supplicant-wlan0.conf

country=DE
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

ap_scan=2
network={
    ssid="name"
    mode=2
    key_mgmt=WPA-PSK
    psk="passphrase"
    frequency=2412
}

Deactivated hostapd by running systemctl disable hostapd.service and enabled wpa_supplicant by runinng systemctl enable wpa_supplicant@wlan0.service.

After a reboot I can see hotspot but not connect to it. What am I missing?

  • How do you try to connect? With a mobile phone? How much character has the passphrase? What error message do you get? Look with systemctl status wpa_supplicant@wlan0.service and with journalctl --boot --unit wpa_supplicant@wlan0.service. For feedback on this please edit your question. – Ingo Dec 17 '18 at 23:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.