0

Today I installed Raspbian Stretch Lite once again on my Pi.

After that I connected my Pi to the Internet using a WLAN USB adapter. I can ping, for example, Google but not my PC on my local network. Also, I can't ping my Pi from my Windows machine.

The strange thing is that I can connect to my Pi using my smartphone, which is also connected to the same WLAN.

Also, I connected my Pi to my network using an Ethernet connection to test if this would change something, but it didn't.

Output of ip addr (I am currently using the WLAN Module from the Pi for these outputs!)

1: lo <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000  
  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00  
  inet 127.0.0.1/8 scope host lo  
    valid_lft forever preferred_lft forever  
  inet6 ::1/28 scope host  
    valid_lft forever preferred_lft forever  
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000  
  link/ether b8:27:eb:6e:9e:6a brd ff:ff:ff:ff:ff:ff  
3: wlan0 <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000  
  link/ether 80:1f:02:f6:f9:00 brd ff:ff:ff:ff:ff:ff  
  inet 192.168.178.38/24 brd 192.168.178.255 scope global wlan0  
    valid_lft forever preferred_lft forever  
  inet6 fd00::5da1:13b6:fefb:ed29/64 scope global mngtmpaddr noprefixroute dynamic  
    valid_lft forever preferred_lft 3444sec  
  inet6 fe80::6d34:3ad9:6b85:15b5/64 scope link  
    valid_lft forever preferred_lft forever  

IP Route:

default via 192.168.178.1 dev wlan0 src 192.168.178.38 metric 303  
192.168.178.0/24 dev wlan0 proto kernel scope link src 192.168.178.38 metric 303

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev  
update_config=1    

I normally use this to configure the WLAN Adapter in the sudo nano /etc/network/interfaces .

# WLAN
allow-hotplug wlan0
iface wlan0 inet manual
wpa-ssid "WLAN-NAME"
wpa-psk "WLAN-PASSWORT"

Edit: I am using a Raspberry Pi 2B+ not a Raspberry Pi 3. I have both, but i want to use this Raspberry as a NAS.

  • How is your network set up? What router do you have? Have you split 2.4 & 5GHz networks with different SSIDs? Have you disabled any firewalls within the LAN that might block one LAN device from another? – Dougie Dec 17 '18 at 21:27
  • 1
    Start by learning what IP addresses are assigned to your devices... sounds like you've got different subnets. – Seamus Dec 18 '18 at 0:39
  • I assume you are using a Raspberry Pi 3 Model B. This has a built-in wifi chip. Is it possible that there are a conflict with the additional WLAN USB adapter? Do you need it to connect to two wifi networks or do you disable the onboard chip? Can you please edit your question and add the output of this commands ip addr and ip route and sudo cat /etc/wpa_supplicant/wpa_supplicant.conf (without showing password and compromising settings). Please address me with @Ingo, otherwise I won't see your reply. – Ingo Dec 18 '18 at 9:53
  • You've not mentioned which version of Windows you have. If you are trying to ping your Pi by it's raspberrypi.local address then you may need to install the Bonjour service for it to work or otherwise use the numerical IP address. – Roger Jones Dec 18 '18 at 10:18
  • @Ingo I updated my initial question with the output of the commands. – Simagdo Dec 18 '18 at 15:25
0

In my comment to the question I assumed you are using a RPi 3B. So I do not understand why do you mention a second WLAN USB adapter in addition to the on-board wifi device when it does not play a role. Anyway the setup you show is as usual with one exception. /etc/wpa_supplicant/wpa_supplicant.conf must have settings to find your WLAN. Something like

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
    ssid="wlan@hoeft-online.de"
    psk="verySecretPassword"
}

and described at Setting WiFi up via the command line. Because your RasPi is connected to the WLAN you must have another configuration file for wpa_supplicant. I don't know what you have configured but with problems it is best to start over again with default configuration.

Everything seems to work except connecting to the MS Windows PC. This can have mainly two reasons: the PC is not connected to the same WLAN than the RasPi. If it can connect to the internet then there must be another path to the web. Look at the network configuration of the PC if it is member of the same subnet than the RasPi, that means using the same address range. If so then the only possibility I see why it does not work is the firewall configuration of the PC. For testing disable it.

  • i have updated the initial Question how i normally setup the WLAN Adapter, i will try your solution, when im at home. – Simagdo Dec 19 '18 at 6:48
  • i have tryed what you suggested, but it still not work. I disabled my Firewall to test if there is an error. But i still can't ping my Raspi. I also tryed to ping my Smartphone, which is also in the same Network which neither worked. So i thing, theres an Problem with a Setting in Windows but i don't know, what i could try next ;/ – Simagdo Dec 19 '18 at 18:50
  • @Simagdo Now we are on MS Win and it doesn't belong to Raspberry Pi. But it seems that the PC isn't connected to the same WLAN than the RasPi and the Smartphone. You should look in that direction why it does not connect to your WLAN router. Maybe it connects on a 5GHz band and the RasPi is connected on 2.4GHz and the router does not join this. Then you can look at the router for a configuration option. – Ingo Dec 19 '18 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.