1

After updating to Raspbian Stretch (kernel 4.14.90-v7+), my Playstation 3 Eye camera is no longer detected on any of the three Pi3 Model Bs that I have. lsusb does not report the device and dmesg shows no error. vcgencmd get_camera > supported=0 detected=0.

I tried adding to boot modules, bcm2835-v4l2, and gspca_ov534 as suggested in some Ubuntu forums, but none of these helps. I have tried the camera with and without a USB power hub, again with no success. The problem persists on fresh installation of Stretch.

The camera works fine in Ubuntu 18.04 and Debian Stretch on amd64 machines. On my Pi, an old Creative Webcam is detected and works.

Any help will be greatly appreciated.

Thanks and Happy Holidays!

  • My PS3 camera works on my Pi3 with the latest Raspbian Stretch. Are you able to do a fresh install of the latest Raspbian Stretch rather than an update? – CoderMike Dec 22 '18 at 11:53
  • Yes. My PS3 fails on fresh installations of Raspbian Stretch. I have a machine running Debian Stretch (amd64), PS3 Eye works fine on it. – Shaker Dec 22 '18 at 14:31
  • CoderMike: That your PS3 Eye works Raspbian Stretch gives me hope! Did it work out of box? Do I need to modify any settings in /boot/config.txt? Could you please tell me what driver module is being loaded and used? Thanks. – Shaker Dec 22 '18 at 17:14
  • Yes, worked out of the box. Didn't modify anything. Away from home at the moment - will try and remember to check when home. – CoderMike Dec 22 '18 at 22:32
  • Thanks for your quick reply in the middle of holidays. When you get to it, could you also please check for me the kernel version? Thanks. – Shaker Dec 22 '18 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.