0

I am trying to set up my Raspberry Pi as a DNS blocker on my network. but whenever I try to add the ip address and password, I get the prompt "It only works with version 3." Or when I mess around with other settings, a "Cannot connect"

I verified that pi-hole API Version is 3 and using a Raspberry Pi 3B I'm running Raspbian version 9 and updated debian version to 9.6

My raspberry pi can ping the devices on the network. The only thing I can think of is that for my apartment complex internet, DNS server IP addresses get filled out in my internet settings and I had to use that address for DNS to allow my raspberry pi to connect outside the network.

  • 1
    I figured it out, I had to re-run: "curl -L install.pi-hole.net | bash" – Derek Dec 22 '18 at 1:59
  • 3
    Feel free to expand on that solution and submit it as your own accepted answer. @Derek – trishmapow Dec 22 '18 at 9:53
0

The questioner has found a solution as written in a comment:

I figured it out, I had to re-run: "curl -L install.pi-hole.net | bash"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.