0

I've been struggling with a Raspberry Pi wifi issue for about 3 hours.

I cannot get my Rpi0W to connect to the network in headless mode.

Here are my steps: - Downloaded Raspbian and flashed the drive with etcher - Opened boot partition on another machine and put in a file called wpa_supplicant.conf

update_config=1
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
country=US

network={
    ssid="My WiFi 2.4"
    psk="mypassword123"
    key_mgmt=WPA-PSK
}

the configuration was set to connect to my phone's network. I verified it was using UNIX line endings and the network is spelled correctly. I've also tried turning my wireless network's password off and no connection anyway.

I know this seems to be asked a lot but I've also been reading a lot and can't seem to find anything that helps.

  • 1
    It is difficult to see whether your wpa_supplicant file is correct - you should post as code (using the "{}" button). How do you know it isn't working - what did you try that wasn't working - and WHAT are you trying to connect to? – Milliways Dec 22 '18 at 4:23
  • Edited to see the code. I'm trying to get my raspberry pi zero w to connect to a wifi network. I know it isn't working because I can see on the network no devices are connected. I've tried a number of things that didn't work, I've listed as many as I could think of in the short paragraph right after the file. – AirmanEpic Dec 22 '18 at 4:27
  • 1
    That looks OK (assuming SSID & password are correct, and not using any "funny" characters - which iPhones do). There is little that can be done to test without keyboard & screen. PS update_config=1 is normally 2nd line, but I don't think that is significant. – Milliways Dec 22 '18 at 4:39
  • The conf file seems to be valid. For testing purposes I'd change the SSID to a string without dot and spaces, i.e. mywifi24. Btw: you could store the wifi password encrypted in preference to plain text, see raspberrypi.stackexchange.com/a/91636/78211 – Fabian Dec 22 '18 at 10:24
  • 1
    In addition to use a simple ssid you should use a password at least of 8 character. I have heard that a password of 4 character was silently rejected on a router. – Ingo Dec 22 '18 at 21:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.