0

I'm trying to use Redshift on my Raspberry Pi, but running redshift -O 2500 gives the error

Gamma ramp size too small: 0
Failed to start adjustment method randr.
Trying next method...
Using method `vidmode'.

I've seen that I have to enable OpenGL graphics from raspi-config > Advanced Options > GL Driver, and other posts say there should be an option to enable "Experimental OpenGL Driver".

But on my version (just upgraded to Raspbian Stretch), I have 3 options (not "Experimental"):

  • GL (Full KMS)
  • GL (Fake KMS)
  • Legacy

None of them seems to work (I rebooted and got the same error).

Is there any other package to install ? Or is it even possible with Stretch ?


Note: (don't know if this can be helpful) when running minecraft-pi with the Full KMS driver, I got this warning several times:

libEGL warning: DRI2: failed to authenticate

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.