0

I have a Raspberry Pi 3 Model B+. On the initial installation, I was able to select a WiFi network and connect to that in order to download and setup everything I need.

After that, I had to switch to a different WiFi network in order to run tests on the Python code I am running. Upon boot up, I clicked on the "WiFi" Icon on the top right part of the monitor, and it showed me the:

Wi-Fi country not set
Click here to set Wi-Fi country

and this message seemed to prevent me on switching to another network. After setting this, I am able switch networks.

However, I noticed that after shutting down, leaving the board with no power, and then turning it back on, it goes back to the old scenario and the Wi-Fi Country has been un-set, and I have to set it again in order to see the other Wi-Fi networks available.

The board still seemed to connect to it's last known network. However, aside from that, there was an instance where it wasn't able to connect properly to its last known network. Even after setting the Wi-Fi country and seeing the other available networks, it wasn't able to see it's "home" network, even if the other devices we had were able to detect the "home" network.

I'm using the latest version of the Raspbian OS.

  • List the contents of /etc/wpa_supplicant/wpa_supplicant.conf (you will need to use sudo). – Milliways Dec 24 '18 at 6:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.