3

I use kodi with libreelec on a raspberry pi 3. But after 30 seconds it stutters and hangs for a short time, then the movie continues and stutters again after 15-30 seconds.

I tried to set a maximum bandwidth in the widevine settings and it did not change anything. Then I changed stream selection to manual and now I get the minimum quality, which is way too bad with large artifacts even in the netflix logo (the internet connection has 50 MBit/s). I do not see anyway where the manually select the stream, I thought this actually enables the selection by the specified minimum/maximum bandwidth?

The 1080/720p setting didn't seem to have any effect (with automatic stream selection) either.

Do I even need to worry about the network, or is a pi too slow for high quality netflix? Where can I select a medium quality?

3

The raspberry pi 3 is not fast enough for 1080p, because widevine does software decoding because of the DRM In the netflix plugin it is a bit confusing how to set the bitrate in a permanent way.

I had to select manual stream selection and then start a video and choose 720p stream there and then save it as default. It still forgot it the first time, but when I did the same again, it now seem to remember the bitrate.

So you need to:

  • Go to the widevine input stream settings and select manual stream selection
  • Start a video
  • Open the menu and select "video options"
  • Select the bitrate option
  • Use the highest bitrate 720p option (or lower if your internet connection is slow as well)

Now it should run just fine.

  • I did not find a way to make libreelec remember this setting. The button to make it the default doesn't seem to work or at least not after closing the netflix app – allo Jan 14 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.