1

I got a Raspi Zero W which I unwrapped myself today. I flashed a Micro SD with the latest Raspbian Stretch Lite, put it into the card slot and hooked it to a 5V 1.2A power cable I've been previously using with my Raspi B+ (1st gen). I used the adapters that came along with the Raspi to attach my HDMI monitor and my USB keyboard (work fine with Raspi B+).

For the first three times the screen stayed black and would flicker into some red-ish content for just a splitsecond so I couldn't read what it said. Then I tried a regular phone charger (5V 0.7A) and the screen stayed black again. Now the Raspi doesn't start at all anymore with either cable and the ACT LED doesn't turn green anymore either.

Did I brick my Raspi Zero W? Any clue what might've caused the screen to stay black?

Thanks in advance

  • 1
    does the SD card work in the pi1 (with appropriate adapter of course) – Jaromanda X Dec 25 '18 at 23:11
  • 1
    I suspect the sd card has corrupted. Try re-flashing it. – CoderMike Dec 25 '18 at 23:13
  • I just re-flashed the card and then put it in the pi1 and the system boots just fine. Then I removed it from the adapter and put it back in the Raspi Zero W. Fortunately the green ACT LED flashes again for a while and then stays on permanently. Unfortunately the screen stays black again. Has been like this for at least a full minute by now and there's no screen flicker. FYI I'm using Raspian Stretch Lite. – oschlueter Dec 25 '18 at 23:20
  • Try a better power supply. Try setting up SSH and WIFi (/etc/wpa_supplicant/wpa_supplicant.conf) on your other RPi. Read raspberrypi.org/forums/viewtopic.php?f=28&t=58151 – Dougie Dec 26 '18 at 6:24
  • Thank you @Dougie if you would submit your response as an answer I'd like to accept it. The screen is still black and after putting the card into my pi1 the screen stayed black as well so I had to re-flash it. I don't really care about that so your suggestion to set up SSH and WiFi on a different device works for me! – oschlueter Dec 26 '18 at 10:24
1

Try a better power supply. Try setting up SSH and WIFi (/etc/wpa_supplicant/wpa_supplicant.conf) on your other RPi. Read https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=58151

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.