0

Long story short, my mic was working fine yesterday. I then had a pair of USB speakers connected and then again disconnected. And now I cannot get the little thing to do a arecord with using the "-D" parameter.

My setup is currently a monitor with HDMi and sound output (works perfectly), 1 USB mic (did work fine, but now doesnt).

**** List of CAPTURE Hardware Devices **** card 1: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: subdevice #0

**** List of PLAYBACK Hardware Devices **** card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 7/7 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0

alsa.conf:

defaults.ctl.card 1 defaults.pcm.card 0 defaults.pcm.device 0

cat /proc/asound/cards

0 [ALSA ]: bcm2835_alsa - bcm2835 ALSA bcm2835 ALSA 1 [Device ]: USB-Audio - USB PnP Sound Device C-Media Electronics Inc. USB PnP Sound Device at usb-3f980000.usb-1.1.2, full s

My ~/.asoundrc

pcm.!default { type hw card 0 }

ctl.!default { type hw card 1 }

I am fairly new to this so I might have missed something obvious, but any pointers are appreciated.df

  • your title says it only works with -D - but the body of the question states cannot get the little thing to do a arecord with using the "-D" parameter. and then there is no example of using -D anywhere - so, confused – Jaromanda X Dec 27 '18 at 21:24
  • ahh forgot to add it :P I have been doing some ts since, so I cant even replicate the issue anymore, though I have gotten it narrowed down to it being a problem with the mic not being set up correctly. Which is weird as it was working perfectly fine right after I installed it, but after I had some usb powered speakers connected it messed up my mic it seems.. – Rasmus Thorslund Dec 29 '18 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.