0

I was booting for the first time a Raspberry Pi with NOOBs, the installation was doing fine until it got stuck for more than 20 min. After a quick read on the internet it was apparently fine to power-off the raspberry.

I removed the SD card and put it in my MacBook to do a clean install, however I realised that the SD card wasn't appearing, either on disk utility or in the terminal. I tried to reboot my laptop, nothing changed.

Finally I tried to slide down the little switch on the side of my SD card adapter, and now I can see two partions : RECOVERY and boot. If I understood correctly my micro SD card is in read-only mode. How can I erase my card if it is only appearing in read-only?

  • 1
    SD cards have no such thing as read-only mode - the readers can detect the position of the plastic "switch" if they want to (the raspberry pi for example does not) – Jaromanda X Dec 27 '18 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.