0

I thought I could power a fan by connecting each of its rudimentary wires to pins 2 and 4 (5v pins) on the raspberry. Immediately, the screen the pi was connected to went blank, even though the pi was plugged in. The PWR (not the ACT) LED stayed on but now the pi won't boot. Question 1: what is now broken on my pi? Question 2: can I fix it in any way? imitation of me connecting the fan to the pi with rudimentary wires fan specs: 12 volt DC, 0.15 amps, 1.8 watts

  • What you describe shouldn't have caused a problem. That probably means you did more than you described. Exactly what did you connect to what? – joan Dec 27 '18 at 19:21
  • Welcome. It is possible you briefly touched a ground or 3.3V if you did this the way you are in the picture. In future consider connecting the pins to a breadboard so the contacts are separated better. BTW, the "rudimentatry wires" of a simple DC device are power and ground, not power and power (this is a simple process of elimination, since a DC device needs at least those two things to work). Wiring it up that way would probably just do nothing though, I agree with joan that it shouldn't have damaged the Pi. – goldilocks Dec 27 '18 at 20:16
  • Do you mean pins 2/6 or 4/6 as 2 and 4 are both 5v, with 6 being ground? – Andy Anderson Dec 27 '18 at 20:18
  • 2
    @goldilocks, yeah I probably touched the ground or 3.3v. I guess my answer is basically a combined duplicate of raspberrypi.stackexchange.com/questions/40267/… and raspberrypi.stackexchange.com/questions/85338/…. Thank you for explaining everything to me, as I am a complete beginner with raspberry pi. – id-bnstra Dec 27 '18 at 20:58
  • Welcome to the Raspberry Pi flavoured corner of the Stack Exchange network. It sounds like you have gained the dubious honour of a question that can have the rip! – SlySven Dec 28 '18 at 1:31
-2

GPIO pins Raspberry Pi GPIO layout shows pins 2 and 4 are 5v and pin 6 is Ground.

Not the answer you're looking for? Browse other questions tagged or ask your own question.