0

I used the 64-bit CURRENT build and copied the image to my microSD card. During the boot process my Pi is hanging on network configuration. Is the Pi 3B+ officially supported and how can I fix the problem?

  • 1
    Please read this post, do some research, and ask a more specific question please. And @Ingo's answer may be likely to get you where you want to be. – Seamus Dec 28 '18 at 14:27
  • @Seamus the post you linked is very out of date. It does have a more up to date answer well below the out of date answer, but the poster already linked to the correct place from that answer. They also asked a specific question "how can I fix the problem" – T. M. Dec 28 '18 at 15:00
  • @T.M.: If you'll read the entire thread, you'll find a post at the bottom that's fairly current (April, 2018), and potentially useful. And wrt to your opinion on being a specific question, No - I disagree with you - it is not a specific question. – Seamus Dec 29 '18 at 11:50
  • @Seamus I saw that answer and mentioned it. Actually looking at it more, that answer is still out of date too for the 3b+ since it links to the armv6 version, while the poster linked to the latest aarch64 code the 3b+ can take advantage of. Also he specified a problem and asked how to fix it. I'm not trying to be argumentative, but that's plenty specific to give the needed answer. – T. M. Dec 29 '18 at 12:00
0

I just checked and FreeBSD-12.0-RELEASE works fine with the 3b+ so I suggest you use that.

Generally unless you're comfortable with bugs and debugging, you want to run FreeBSD-release rather than FreeBSD-stable and especially FreeBSD-current.

I didn't explore further because the on board wifi for the 3b+ doesn't have a working driver on FreeBSD and I don't have a USB wifi that works. But wired networking works fine.

Also to answer your question the 3b+ is not officially supported by FreeBSD, as well as FreeBSD not being officially supported by Rpi or Noobs like Ingo mentioned.

  • Finally I had some time to test things. Thanks for your comment, your linked version works fine for me. I downloaded the wrong ISO file in the first place, now everything is working as expected. – jaegerschnitzel Jan 7 at 18:59
  • @jaegerschnitzel Glad it worked. I did end up playing around with it more and it's a lot more useful if you enable some swap as the default image doesn't have it enabled. It even better if you attach a USB hard drive and put the swap and filesystems on that. – T. M. Jan 7 at 22:56
0

On the download site for Raspberry Pi operating systems you can find:

Raspbian is our official operating system for all models of the Raspberry Pi. Download it here, or use NOOBS, our easy installer for Raspbian and more.

There are other operating systems on that site called Third Party Operating System Images but not called official and FreeBSD is not even part of it. So I would say you should ask at freebsd.org for support. Or maybe you will find someone here on our site who have experience with your problem.

It is also worth to check the FreeBSD image against the driver issue for RPi 3B+. This model needs new drivers in the images so the image should not be older than 2018-03-14. But of course, this doesn't guarantee it has the updated driver. For information about this issue look at Why am I getting a rainbow screen and flashing red PWR LED with a new Raspberry Pi 3B+?.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.