I have a Raspberry Pi 3 and I am struggling with installing Mosquitto. It seems to be caused by a bad mosquitto-jessie.list file:

deb https://repo.mosquitto.org/debian jessie main  

It could not find any updates (it gives a 404 error all the time). Could someone send a valid mosquitto-jessie.list with its contents? (I have tried to download it again with wget)

I am getting hints to install from Instructables.

It seems also that this is duplicated with this topic

  • Welcome to Raspberry Pi! Please take the tour and visit the helpcenter to see how things work here. If you work out a solution based from that new link you have included, feel free to post an answer yourself. – Ghanima Dec 30 '18 at 17:47
  • Mosquitto v1.4.10 is available in the Raspbian Stretch repositories (by just running sudo apt install mosquitto without editing any configuration). Would that be acceptable or do you specifically need a newer version? – Aurora0001 Dec 30 '18 at 17:59
  • I am opened to any version of mosquitto, but as I run this exact command I get bunch of Ign/errors that repo.mosquitto.org/debian/dists/jessie/main/binary-armhf/… nor archive.raspberrypi.org/debian/dists/jessie/main/binary-armhf/… cannot be found. This outupt I get without any modification, only apt-get install command – Mzw Dec 30 '18 at 18:19

Ok with some help I found answer. It wasnt obvious,but I had proxy set up which redirecting gzipped package somewhere else. So for me deleting file /etc/apt/apt.conf.d/10proxy and rebooting system did the work. Sorry for posting question and answering it so fast, but before posting I spend 2 days trying to solve this

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.