0

I'm trying to connect my rpi zero in a headless mode into a WIFI network configured in a WPA mixed mode.

More specifically I can get the following info from the router.

Security-Mode: WPA2-Mixed
Encryption: TKIP + AES
Wireless network mode: Mixed
SSID: HANET
Passphrase: @123ABCwe@

So according with the different articles that I've found online, inside the /etc/wpa_supplicant/wpa_supplicant.conf file I'm having the following:

zcountry=GR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="HANET"
    #ssid="ComputerCenter"
    scan_ssid=1
    psk="@123ABCwe@"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    group=TKIP
    auth_alg=OPEN
    #key_mgmt=NONE
}

But it seems that RPI never get connected to the wifi because it's not listed inside the router nor found with a simple subnet scan.

Any ideas?

  • 1
    zcountry? should that just be country ... anyway, all I have in my supplicant file after country ctrl_interface and update_config in the network setting ssid, psk and key_mgmt entries - perhaps try with just those and see if that works – Jaromanda X Dec 30 '18 at 23:20
1

Finally the problem was with the typo in zcountry parameter that Jaromanda X noticed. I turned the zcountry into country and now it's working.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.