1

I recently installed a Hyperpixel touchscreen on my Raspberry Pi 3, but I don't want to leave the screen on 24/7 to avoid damage and because an always-on display doesn't fit my use case.

Before I put the screen on this Pi, I briefly had it running with another freshly installed Pi, and there the display automatically switched itself off after 10 minutes or so, automatically waking up when it was touched. For some reason, it doesn't do that on the Pi it's currently on. This particular Pi has been running for over a year, so I can't remember what changes I made to its configuration exactly, and all the google results for "raspberry pi enable screen sleep" are about people who want to disable that, which isn't terribly useful.

The Pi in question is configured to auto-login to the console and start htop in a tmux session. There's no graphical desktop environment. I've seen people mention various xset commands, but those always output xset: unable to open display "" when I try them. Changing the contents of the DISPLAY env variable does nothing.

The few blog posts that I could find that do mention config files are all outdated, as most of the config files' paths no longer exist on Raspbian Stretch.

At this point, I'm at a total loss. What's the canonical, best way to make a Hyperpixel display (and nothing else) on a Raspberry Pi running Raspbian Stretch go to sleep after X minutes?

Addendum: I tried adding consoleblank=180 to /boot/cmdline.txt for a three minute timeout, and while that successfully blanks the display after three minutes, it doesn't disable the backlight. That makes it useless for my purpose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.