I have pi B+ with a new install of rasbian today

I am trying to connect my Samsung Galaxy Edge 6 with a usb cable. I have previously connected the phone to a linux pc using the same cable with no problems. I have tried this with two different cables.

I am following the instructions given here.

However, when I connect to the Pi it goes into a loop, creating error dialogs like the one shown in the image below.

enter image description here

The errors are created continuously as long as the phone is connected. Occasionally, I get a dialog similar to:

enter image description here

As the error refers to udev, I have check the udev directory and as each error dialog appears a file is created in dev/bus/usb/001, and then is deleted immediately.

The problem seems similar to the on described here and here and so I have installed mtp-tools and libmtp-runtime.

When I run lsusb with phone connected I don't get an entry.

enter image description here

Can anyone please help me to find a solution to my problem?

EDIT 20190107 =================================================

This is what I know so far:

I now have a brand new, raw and unmodified installation of Rasbian.

I have two android devices, an S6 phone and a Galaxy tablet. I have multiple cables and have tested both devices on both my Unix platform and my Pi.

                        S6 phone    Galaxy tablet
Unix both usb ports         Y           Y
Unix both usb cables        Y           Y
Pi   both usb ports         N           Y
Pi   both usb cables        N           Y

(Y=works, N=does not work)

So, for some reason the phone is 'seen' on the unix box, but not on the Pi

  • Would the person who gave a -1 for this question please explain why? You can see that I am a new contributor. I have no idea what is required in this sort of question. My internet searches for a solution have proved fruitless
    – Psionman
    Commented Jan 2, 2019 at 14:35
  • Welcome to Raspberry Pi! The one you are asking why he had down voted will not see your comment. You have to address him with @Username ... But for me there is no other information than that you connected your mobile phone with an usb cord to the RasPi and that is has problems then. Please take the short Tour and visit the Help Center to see how things work here and how to ask to get best answers. I have upvoted you for motivation ;-)
    – Ingo
    Commented Jan 3, 2019 at 0:29
  • your question is not really an RPi question .... it is a linux question
    – jsotola
    Commented Jan 3, 2019 at 1:51
  • @Ingo Thanks. I'll take your advice and revisit the question
    – Psionman
    Commented Jan 3, 2019 at 13:50
  • @jsotola the Raspberry Pi has a problem, isn't it?
    – Ingo
    Commented Jan 3, 2019 at 23:00

1 Answer 1


I suppose you want to use USB tethering to connect to the internet with the mobile phone. The links you are used are completely outdated. They are four or five years old. If you followed that and configured /etc/network/interfaces then you are wrong. This isn't used with Raspbian Stretch anymore by default. It uses dhcpcd. Also installing mtp-tools and libmtp-runtime doesn't make sense under this conditions.

Raspbian Stretch is configured to work out of the box with USB tethering. I have just tested it with my installation of Raspbian Stretch Lite 2018-11-13. The desktop version should also do. I connected my Samsung Galaxy with an USB cord to the Raspberry Pi and enabled USB-Tethering on the Galaxy in its submenu and it works. I can get into the Internet through the mobile phone.

  • I have just done a complete re-install of Rasbian, re booted and tried to connect the phone having made NO changes to the system at all. I still get the same message. Does this mean a problem with the phone?
    – Psionman
    Commented Jan 6, 2019 at 19:45
  • @Psionman Seems to be. But I will look at the error. What have I to do to get the same error?
    – Ingo
    Commented Jan 6, 2019 at 19:56
  • I have tried another android device on the Pi and it works fine. Must be a phone problem ;(
    – Psionman
    Commented Jan 7, 2019 at 9:03
  • @Psionman Glad that you fixed it :-) If my answer helped you to find the solution it would be nice if you could accept it by clicking the tick on the left side. This will finish the question and show other users that it has an answer.
    – Ingo
    Commented Jan 7, 2019 at 13:20
  • Sorry. It's not fixed. I still need to be able to connect my phone and I cannot. I'm about to edit the question with a summary of my findings so far :)
    – Psionman
    Commented Jan 7, 2019 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.