2

Whenever I run "sudo apt-get update" I get

pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Ign:3 https://dl.bintray.com/etcher/debian stable InRelease
Get:4 https://dl.bintray.com/etcher/debian stable Release [3,674 B]
Get:5 https://dl.bintray.com/etcher/debian stable Release.gpg [821 B]
Ign:5 https://dl.bintray.com/etcher/debian stable Release.gpg
Fetched 4,495 B in 1s (2,470 B/s)
Reading package lists... Done
W: GPG error: https://dl.bintray.com/etcher/debian stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 379CE192D401AB61
W: The repository 'https://deb.etcher.io stable Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'etcher/binary-armhf/Packages' as repository 'https://deb.etcher.io stable InRelease' doesn't support architecture 'armhf'

Is there a way to remove that problematic url from the list that is checked whenever "apt-get update" is run?

  • Just outta' curiosity, did you edit /etc/apt/sources.list? If not, do you know how these other sources were added? – Seamus Jan 3 at 20:09
  • I was installing Etcher and ran a Bash command which apparently appended the file. – user96931 Jan 3 at 22:27
5

All the repository URL's are in the apt source files.

The main source file is /etc/apt/sources.list. You can edit the file with e.g. nano to remove the offending 'etcher' line(s):

sudo nano /etc/apt/sources.list

You also need to check the 'secondary' list files. That is any .list file in directory /etc/apt/sources.list.d/. You should find e.g. raspi.list in there, which points to the RPF repositories. You need to check all the list files in there and if necessary edit the file.

0

For thoose who get the same error I used to manage it in adding dirmngr package

apt-get install dirmngr

and add manually the missing keys

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys YOUR_KEY_HERE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.