0

im having some issues with accessing the 6lbr web server page. I just need to know what is the output you get once you checked your interfaces by entering "ifconfig". In mine, I just get only the details about loopback interface and eth0 interface. I really appreciate your help because I have stucked in this point for more than 2 weeks now :( Im using raspberry pi 2 and raspbian wheezy is installed

  • I just get only the details about loopback interface and eth0 interface - what else were you expecting? – Jaromanda X Jan 4 at 12:35
  • Doesnt it show any details related to tap0 , br0 interfaces? Btw Im running 6lbr in the router mode. – Udana Pasan Jan 4 at 13:02
  • ifconfig is deprecated. You should use ip from the iproute2 package. Why do you expect that a web server will install a virtual private network (interface tap0) and a bridge (interface br0)? Web server I know only use the available interfaces (e.g. eth0). Please address me with @Ingo, otherwise I won't see your reply. – Ingo Jan 4 at 22:58
  • @Ingo thanks for the comment. When I install the 6lbr, I added these configuration to the 6lbr.conf file. "MODE=ROUTER RAW_ETH=1 BRIDGE=0 DEV_BRIDGE=br0 DEV_TAP=tap0 DEV_ETH=eth0 RAW_ETH_FCS=0 DEV_RADIO=/dev/ttyACM0 BAUDRATE=115200 LOG_LEVEL=3" So I suspect that when 6lbr service is started, it should show the interfaces related to tap0 and br0. Correct me if im wrong. – Udana Pasan Jan 4 at 23:50
  • Seems to be a special case for 6lbr but not for Raspberry Pi. Look with ip link show if you see other interfaces. If not then 6lbr doesn't work as expected. Is there an installation instruction or an image for Raspberry Pi? – Ingo Jan 5 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.