1

I just bought an Raspberry Pi Zero unit that came with Vilros utils. I get within the package a 16gb SD-Card that was pre installed with NOOBS.

When I received the package, I looked inside the SD-Card and saw a lot of files that didn't mean really anything to me.

I tried to plug the Pi zero unit with the SD-Card and power cable. Once started, I saw a window on my screen that asked to install the raspbian. I plugged a mouse and a keyboard which didn't had any effect or worked on the raspberry pi zero. I used Vilros USB-Hub which i connected the mouse and keyboard to.

So, I decided to install the Raspberry Pi Zero unit with burning the image with the Etcher tool. Once I did it and connected the Pi Zero to power and HDMI cable I saw a black screen.

Note - when I plug the SD-Card to my laptop I'm receiving messages from windows that the SD-Card is split to partitions.

Well, after a long reading I would like to ask:

  1. Are the partitions necessary on the SD-Card for the raspberry pi units?
  2. What were the files I saw on the SD-Card when I first plugged it?
  3. How can I continue from the point I am to install the raspbian image?
  4. Is there any significant difference between normal and NOOBS installation only from the part that NOOBS is a easier installation?
  5. Is there a reason why the mouse/keyboards haven't worked?

I tried searching relative subjects to my scenario but I'm pretty a beginner in terms of working with Raspberry pi units.

If something is not understandable from written I'm sorry and I will try to explain myself if needed.

Thanks heads up :)

  • Vilros has customer support which should be able to help you with the system they have installed. If you need help with the image you have flashed, tell us which image that is. – Dmitry Grigoryev Jan 7 at 9:19
1

It is not entirely clear just what you did, but if you used Etcher the SD Card is overwritten. It is now effectively "empty" - you need a fresh start.

I suggest you forget NOOBS (see Should I install NOOBS or Raspbian? for my reasons) and install Raspbian. Follow the linked instructions.

I can't say why the (undefined) keyboard or mouse don't work without knowing what they are.

The answers to your other questions would be long and involved, but you should learn more after successfully installing an OS.

  • First of all, thanks for the response. I would try to install the Raspbian with etcher with another image, and will see the results. – Ido Magor Jan 5 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.