0

I am using a Raspberry Pi Zero with NOOBS downloaded onto the SD Card. It succssfully boots, and asks me to pick an OS. I pick Raspbian and press install, and the install will go ahead for about 2 seconds, and will get stuck on "Raspbian Full: Creating Filesystem(FAT)". The mouse and keyboard are unresponsive and the light also doesn't flash after it has reached this point, so it clearly is repeatedly crashing. I have waited about 2 hours for it to load and tried unplugging and replugging in the power and nothing will happen. I'm pretty sure that NOOBS has been downloaded correctly, considering it's working fine. Is my RPi Zero not powerful enough to download Raspbian without crashing? I used to have LibreELEC on the same RPi Zero, and it worked perfectly. By the way,, I have not plugged in an ethernet cable into the Pi as of yet, but I assume that it will not make a big difference to "creating filesystem".

Hope someone can help, thanks.

  • 1
    It's most likely a failed download, a worn out SDCard or a fake SDCard. Try again with the SD Association formatter to reset the SDCard and NOOBS 3.0.0 or PINN V3.0.1 github.com/procount/pinn. If the SDCard is larger than 64GB you need to muck about with creating a 64GB FAT32 partition before trying to use NOOBS. – Dougie Jan 5 at 19:25
  • Thanks for the advice, I think I'll just download Raspbian, I'm not too sure what difference it makes to download it through NOOBS, I'm new to Raspberry Pi's – Nainman Jan 5 at 19:51
  • Its simpler just downloading Raspbian. Use Etcher to flash to sd card. I gather Noobs takes up some unnecessary space. – CoderMike Jan 5 at 19:54
  • Will Raspbian download as an .img, or will it download in a compressed folder (like NOOBS). Sorry, I'm new to RPi – Nainman Jan 5 at 19:57
  • Raspbian will download as a zip compressed image. You can (but must not) unzip it and have the *.img image. – Ingo Jan 5 at 23:26
0

This is a guessanswer, but it sounds like you may have the "Lite" version of NOOBS on your SD card. If so, you'll need to connect your RPi to the Internet to fetch the Raspbian OS. Alternatively, you could install the heavy (?) version of NOOBS which includes Raspbian, and therefore does not need an Internet connection (to install Raspbian at least).

If that's not it, you've tripped up somewhere else, so read (or re-read) the docs:

NOOBS

How to install NOOBS

  • 1
    Thanks for the help, I've checked again at what I have downloaded, and it is definitely the correct version of NOOBS, I'll try to download Raspbian straight, without NOOBS if possible. – Nainman Jan 5 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.