0

I have Raspberry Pi 3 B+ and I tried to apply some answer in GitHub for a problem that I faced before. https://github.com/adafruit/Adafruit_Python_DHT/issues/63

The problem is that when I run these commends

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764
sudo reboot

My raspberry pi doesn't connect at all and only red light turn on and off. I tried to use TTL-to-USB cable.

I will appreciate any help.

1

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."

sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

You COULD try rebooting to a root shell and can repair most such problems on the Pi.

  1. Append init=/bin/sh at the end of cmdline.txt and reboot.
  2. After booting you will be at the prompt in a root shell.
  3. Your root file system is mounted as readonly now, so remount it as read/write mount -n -o remount,rw /

You can then edit files or restore kernel/bootcode.

  • Sorry, I can't connect the raspberry pi and I'm using win10. So, where should I run this commend? – i_th Jan 6 at 5:43
  • You have broken Raspbian by running unsupported programs. Restore from your backup or re-install. There are lots of tutorials running DHT sensors on the Pi which don't involve all the questionable things Adafruit suggests. – Milliways Jan 6 at 5:48
  • There a lot of work there and I don't have any backup. If I copy the folders of the module and Install the same OS, do you think it will be working again? – i_th Jan 6 at 5:53
  • If you can't boot the Pi your only option is to re-install - you could use a fresh SD Card. You COULD try rebooting to a root shell as in raspberrypi.stackexchange.com/a/92711/8697 but this needs direct connection – Milliways Jan 6 at 5:59
  • @i_th Or put Raspbian on a fresh SD card and use a USB SD card reader to get important stuff off the problem card. – Dirk Jan 6 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.