1

I'd like to install setfacl to enable unprivileged become on my Ansible playbooks.

To that end, I'm attempting to find the binary it says it needs. However, I can't seem to get it to install:

pi@media-pi:/tmp $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
pi@media-pi:/tmp $ apt-cache search setfacl
pi@media-pi:/tmp $ sudo apt install acl
sudo apt install acl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package acl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'acl' has no installation candidate

Where can I find the package that provides that?

  • clearly you've broken something, acl is the package you want' – Jaromanda X Jan 6 at 8:04
  • Try installing aptitude and using that to install acl. Aptitude is better at resolving dpkg conflicts than apt or apt-get. – Dougie Jan 6 at 10:55
3

The package you need to install is acl from the default Raspbian repository. I don't know what operating system and/or repositories you are using with installed Ansible but on my default Raspbian installation I get with:

rpi ~$ apt show acl
[..]
Description: Access control list utilities
 This package contains the getfacl and setfacl utilities needed for
 manipulating access control lists.

So if using default Raspbian you should check your sources.lists and install acl:

rpi ~$ cat /etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi

rpi ~$ cat /etc/apt/sources.list.d/raspi.list
deb http://archive.raspberrypi.org/debian/ stretch main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ stretch main ui

rpi ~$ sudo apt update
rpi ~$ sudo apt full-upgrade
rpi ~$ sudo apt install acl

If it is not working you may try to reinitialize the package lists. Look at Upgrade or install using apt-get results in dpkg error.

  • The sudo apt update step seemed to be the kicker. No idea why everything else went out of sync. Thanks! (the final steps were sudo apt update && sudo apt install acl) – Chris R Jan 6 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.