I've tried a whole bunch of media center systems for my fresh RaspberryPi 3B+. The most interesting one for me is openELEC, but unfortunately it is the only one I can't seem to successfully run - neither version 8.0.4 nor version 7.0.1.

I'd love to upload a photo, but am not yet allowed to do this, here, so I decribe it: Right after powering on the device I see a square of color gradients and a lightning symbol like this:

Red - Yellow       [Yellow Lightning]
 |      |
Blue - Cyan

This is where booting stops. Neither keyboard nor mouse nor ethernet seems to be powered on and therefore the system doesn't react on any input. Only the red LED on the device blinks irregularly.

I came upon some articles warning of a set of non-working SD cards and a table with them, here, where I couldn't find any exact match with the ones I have, but similar cards would work according to the table. For the sake of completeness, this is all information I have about my SD cards:

  • Panasonic microSDHC Class 4, 16 GB, E316G1236 TPSPM20930325 UE2IA004714 (nothing similar found)
  • SanDisk microSDHC Class 4, 8 GB, MMBTR08GUBCA-ME I CYE161GA 122 (many similar are OK)

Furthermore, I also tried disconnecting peripherals and another power supply - to no avail.

Has anyone had the same problems and found a solution?

Any help would really be appreciated. Thanks in advance.

  • 2
    I don't believe the OpenElec images have been updated for the Pi3B+ yet - hence the rainbow screen. – CoderMike Jan 6 at 23:44
  • try libreElec instead? – Jaromanda X Jan 7 at 0:59
  • Just to clarify other comments the "rainbow square" is a symptom of an out of date kernel/firmware. You could try sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel to update BUT this needs to be run on an older model which boots. – Milliways Jan 7 at 4:04
  • 1
    or try libreELEC - it works with 3B+ – Jaromanda X Jan 7 at 7:12
  • @CoderMike: I read something like "same image for pi 2 and 3", but I may have missed the Pi3B+ fact. – Chris Tophski Jan 7 at 21:58

Apparently, as of today, 8th January 2019, OpenELEC does not "support" the Raspberry Pi 3B+

LibreELEC on the other hand does. It's a very similar Kodi implementation to OpenELEC, but seems to be more frequent in its releases

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.