I have my rPi hooked up to my printer via USB connection and powered by a power adapter as supplied with the kit from amazon: https://www.amazon.ca/gp/product/B07BD3WHCK/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

The Pi and the printer and plugged into two separate outlets so there shouldn't be a power surge/drop issue.

The Pi is flashed as per the official instructions provided on the OctoPi website using Etcher and the supplied .zip file. From what I understand, OctoPi is built on a lite version of Raspberian. I do the basic wifi setup on my PC, insert the SD card, power the Pi, and it works as it is meant to.

The sequence of events, I shut down the printer using the built-in on/off switch. Upon powering on the printer again, I am unable to connect to OctoPi. Upon connecting a monitor, I discover that there appears to be a boot error identical to this post: Error on Boot. 'No working init found.'

Unfortunately the suggestion there is to do a reflash, and the author is also not using OctoPi.

I found another post that was unfortunately unsolved where the author installed the full Raspberrian as a work-around and suggested it may be a problem with the lite version: SD Card corrupted at shutdown (no gui)

One last note, this has only occurred twice now and the printer power reboot appears to be the common element. I have not attempted to connect the monitor and replicate the situation to see what happens on the Pi as of yet. That will be my next step once I have time.


In an attempt to re-create the issue I hooked up a monitor and power cycled the 3D printer several times with no problems.

I then attempted to cut power to the Pi to see what that might do, and now it appears I'm stuck in a boot loop with an "error -110 transferring data, sector.." to what appears to be about a dozen different sectors.

At this point, I'm going to re-flash again.

Any more inputs or am I still being a tad useless?


Got a new error. I turned off the printer and left the rPi on over the weekend and came back to discover the uploaded image. Because I didn't really see an option, I did a power cycle which resulted in a boot loop and I'm now re-flashing yet again. This is getting to be a little annoying.

Is there something I should be pulling from the SD card before I re-flash that would be helpful information?

Pi Error

Original post

I'm new to the whole Pi scene, I recently got a 3B+ and OctoPi all set up to run my 3D printer (Taz6 if important). It's been running great, however, I've now discovered an apparent trend where if I shut off the printer it corrupts the OS and I have to start from scratch. It can't seem to initialize the boot sequence and according to my research, I'm best off just doing a total reinstall. The whole process is more than a little frustrating.

I get everything set up as per the basic OctoPi instructions and I make sure I run a full update on the Pi when it boots the first time. I saw another post suggesting that running a lite OS might cause some troubles like this.

Any thoughts?

  • i think that you posted incomplete information ..... please add a description of the shutdown sequence that you are using ..... also describe how the RPi and the printer are powered (a diagram would be best)
    – jsotola
    Jan 8, 2019 at 2:11
  • 1
    I saw another post where? suggesting that running a lite OS which one? might cause some troubles like this the internet is full of misinformation - this sounds like a perfect example Jan 8, 2019 at 4:41
  • Welcome. As per the previous comments, please elaborate 1) About how everything is connected and powered, 2) Exactly how you "shut off" the printer, 3) Exactly what happens immediately after you shut off the printer. Edit these details into the question, do not add them as comments.
    – goldilocks
    Jan 8, 2019 at 5:58
  • thank you @goldilocks I hadn't realized my post was a little too basic
    – S7RM7RPR
    Jan 9, 2019 at 2:03
  • Much better. I'm still not sure how much anyone can say here though.
    – goldilocks
    Jan 9, 2019 at 8:10

1 Answer 1


The problem certainly looks like it is SD card corruption, which can happen as a result of arbitrarily cycling the power.

It shouldn't happen during normal operation. Reboots should be obvious in the system logs, OctoPi is Raspbian based, so you could start with /var/log/syslog (you can also use journalctl).

If you can observe with a monitor that it happens exactly when you turn off the printer, it would decisively confirm whether or not that is the cause. If it is, the Pi and software are not to blame. Which is sort of unfortunate, because it means there is nothing you can do about it other than try another 3D printer...

I saw another post suggesting that running a lite OS might cause some troubles like this.

Is magical thinking of the sort whereby someone swears they have a hat that causes it to rain when they wear it. That person may believe this, and may have anecdotal correspondences that "prove" it ("Everytime I wear this hat it rains! Everytime!") but anyone with a rudimentary education in science would observe that there is no possible causation there.

What you could try realistically is another SD card. Some of them fare better than others. However, if turning off the printer really causes the Pi to suddenly reboot, there's not much you can do about it beyond investigate to provide details to either the manufacturer of the printer or of the Pi.

powered by a power adapter as supplied with the kit from amazon

I have a number of those power supplies from Canakit and they are better than anything else I've found at that price (~$15). Unless it is defective it should be fine.

  • thank you for the input! As with all my new endeavors, when anything goes wrong I like to try and get input from those with more experience so I don't get started on the wrong foot. I should actually be able to try an observed reboot today so we shall see if that provides more answers!
    – S7RM7RPR
    Jan 9, 2019 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.