0

I've been having trouble the last two days figuring out why my NetGear 779s modem isn't working fine with Raspbian.

I installed NetworManager, and did sudo systemctl disable dhcpcd and sudo systemctl stop dhcpcd. I believe that's all I did to make my wifi network interface work for me. I installed it in order to have ModemManager too. NetworkManager reports that the connection is up, but it just doesn't seem to work when I ping 8.8.8.8.

I switch the device to modem-mode using:

pi@raspi-sort:~ $ sudo usb_modeswitch -p 0fff -v 0846 -S -W
Take all parameters from the command line


 * usb_modeswitch: handle USB devices with multiple modes
 * Version 2.5.0 (C) Josua Dietze 2017
 * Based on libusb1/libusbx

 ! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor=  0x0846
DefaultProduct= 0x0fff
SierraMode=1

Look for default devices ...
  found USB ID 0846:0fff
   vendor ID matched
   product ID matched
  found USB ID 0424:7800
  found USB ID 0424:2514
  found USB ID 0424:2514
  found USB ID 1d6b:0002
 Found devices in default mode (1)
Access device 007 on bus 001
Get the current device configuration ...
Current configuration number is 1
Use interface number 9
 with class 8

USB description data (for identification)
>-------------------------
Manufacturer: NETGEAR
     Product: AirCard 779S
  Serial No.: 014260001176522
>-------------------------
Send Sierra control message
-> Run lsusb to note any changes. Bye!

After doing that, I check the change with:

pi@raspi-sort:~ $ lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 1: Dev 3, If 0, Class=Hub, Driver=hub/3p, 480M
            |__ Port 1: Dev 4, If 0, Class=Vendor Specific Class, Driver=lan78xx, 480M
            |__ Port 3: Dev 8, If 0, Class=Vendor Specific Class, Driver=, 480M
            |__ Port 3: Dev 8, If 3, Class=Vendor Specific Class, Driver=, 480M
            |__ Port 3: Dev 8, If 8, Class=Vendor Specific Class, Driver=qmi_wwan, 480M

At that point nmcli stats showing:

cdc-wdm0: disconnected
    1 connection available
    modem (qmi_wwan), hw

And to connect the modem I do:

pi@raspi-sort:~ $ sudo nmcli con up "LTE Connection" 
Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3)

And check if it's up... this is the first thing that looks odd to me:

cdc-wdm0: connected to LTE Connection
    modem (qmi_wwan), hw, iface wwan
    inet4 10.0.0.4/24

Then try using ping to check the connection, but it just doesn't work:

pi@raspi-sort:~ $ ping -I wwan0 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from 10.0.0.4 wwan0: 56(84) bytes of data.

LTE Connection is defined as:

pi@raspi-sort:~ $ nmcli con show "LTE Connection"
connection.id:                          LTE Connection
connection.uuid:                        0993532f-4bd9-4703-a6b6-be3a1c20533d
connection.stable-id:                   --
connection.interface-name:              cdc-wdm0
connection.type:                        gsm
connection.autoconnect:                 no
connection.autoconnect-priority:        0
connection.autoconnect-retries:         -1 (default)
connection.timestamp:                   1546902293
connection.read-only:                   no
connection.permissions:                 
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
connection.lldp:                        -1 (default)
ipv4.method:                            auto
ipv4.dns:                               
ipv4.dns-search:                        
ipv4.dns-options:                       (default)
ipv4.dns-priority:                      0
ipv4.addresses:                         
ipv4.gateway:                           --
ipv4.routes:                            
ipv4.route-metric:                      -1
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-timeout:                      0
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv4.dad-timeout:                       -1 (default)
ipv6.method:                            auto
ipv6.dns:                               
ipv6.dns-search:                        
ipv6.dns-options:                       (default)
ipv6.dns-priority:                      0
ipv6.addresses:                         
ipv6.gateway:                           --
ipv6.routes:                            
ipv6.route-metric:                      -1
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       -1 (unknown)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
ipv6.token:                             --
gsm.number:                             --
gsm.username:                           wap
gsm.password:                           <hidden>
gsm.password-flags:                     0 (none)
gsm.apn:                                wap.gprs.unifon.com.ar
gsm.network-id:                         --
gsm.pin:                                <hidden>
gsm.pin-flags:                          0 (none)
gsm.home-only:                          no
gsm.device-id:                          --
gsm.sim-id:                             --
gsm.sim-operator-id:                    --
proxy.method:                           auto
proxy.browser-only:                     no
proxy.pac-url:                          --
proxy.pac-script:                       --
GENERAL.NAME:                           LTE Connection
GENERAL.UUID:                           0993532f-4bd9-4703-a6b6-be3a1c20533d
GENERAL.DEVICES:                        cdc-wdm0
GENERAL.STATE:                          activated
GENERAL.DEFAULT:                        no
GENERAL.DEFAULT6:                       no
GENERAL.VPN:                            no
GENERAL.ZONE:                           --
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/ActiveConnection/3
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/Settings/1
GENERAL.SPEC-OBJECT:                    --
GENERAL.MASTER-PATH:                    --
IP4.ADDRESS[1]:                         10.0.0.4/24
IP4.GATEWAY:                            10.0.0.5
IP4.DNS[1]:                             10.0.0.1

My experience is a bit limited to be able to debug this issue further - I've been stuck here for a while... so any directions to understand what's going on will be appreciated.

  • Network manager isn't supported by Raspbian Stretch by default. Did you install it? What did you do with dhcpcd? – Ingo Jan 8 at 20:20
  • Yes I installed it, and did sudo systemctl disable dhcpcd and sudo systemctl stop dhcpcd. I believe that's all I did to make my wifi network interface work for me. I installed it in order to have ModemManager too. – diegoreymendez Jan 9 at 2:35
1

What helped me debug this issue was using this route testing command, to realize the default gateway was off. My IP for the modem interface was 10.0.0.4 and the default gateway should've been 10.0.0.5.

Running this command:

ip route get to 8.8.8.8 from 10.0.0.4

Was returning 192.168.1.1 as the gateway.

So in conclusion, the solution was 2-folded:

  1. On one hand I had two default routes when running ip route. I removed the one I didn't want to have.
  2. On the other hand the Netgear 779s was just not letting pings go through. The problem was that I was relying on it to know when the connection was up, which is evidently not a great idea. Still not sure why, since there doesn't seem to be any configuration for ICMP within the modem setup, but that's a different story.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.