0
pi@raspberrypi:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up linux-image-4.9.0-6-rpi (4.9.82-1+deb9u3+rpi1) ...
No diversion 'diversion of /boot/vmlinuz-4.9.0-6-rpi by rpikernelhack', none removed.
No diversion 'diversion of /boot/config-4.9.0-6-rpi by rpikernelhack', none removed.
No diversion 'diversion of /boot/System.map-4.9.0-6-rpi by rpikernelhack', none removed.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.9.0-6-rpi

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.9.0-6-rpi with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-4.9.0-6-rpi (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-rpi-rpfv:
 linux-image-rpi-rpfv depends on linux-image-4.9.0-6-rpi; however:
  Package linux-image-4.9.0-6-rpi is not configured yet.

dpkg: error processing package linux-image-rpi-rpfv (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-4.9.0-6-rpi
 linux-image-rpi-rpfv
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@raspberrypi:~ $ sudo apt-get upgrade
  • What is "butal"? Does your RPi fail to boot? – Dmitry Grigoryev Jan 14 '19 at 8:12
1

According to the output posted above:

gzip: stdout: No space left on device

Can you clear some space on the device, to allow the files to be unpacked?

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.