1

I accidentally set it to boot to desktop (gui) instead of boot to console while fiddling with the settings. I don't have a gui installed. Now I cant access the pi over ssh to revert the settings on raspi-config.

Any advice?

2
  • Do you have physical (keyboard, monitor) access?
    – tobyd
    Jan 12, 2019 at 21:44
  • No, i dont have keyboard, monitor access. Jan 12, 2019 at 22:37

2 Answers 2

1

Enable ssh by putting a file called ssh (no extension) in the boot partition in the sdcard. Connect via ssh to the raspberry, then use sudo raspi-config to revert the settings.

0
0

You can force the RasPi to boot into any systemd target with a kernel parameter. For this you have to pull out the SD Card from your RasPi and modify it on another computer. To cmdline.txt in the boot partition append this:

 systemd.unit=multi-user.target

Then it should boot to the console login. I don't know if this also makes ssh available again but it's worth a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.