0

i use this https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md tutorial to turn raspberry pi3 to an access point and also i write a script to hide the ssid and another script to remove the access point but after running each script i should reboot the the raspi to see the changes. i want to know is there a way to switch between access point mode and none access point mode(remove the access point) or access point and hiding the ssid without rebooting the raspi? or is there any script that do this and i can use it? thank you update: the raspi should connect to the internet with ethernet cable while it become an AP and while it switch to the client mode it also connects to the internet with wifi and also ethernet cable.

  • 2
    Possible duplicate of Swapping between wifi client and access point? – Ingo Jan 13 at 21:27
  • 1
    You always ask the same or similar questions switch between access point mode and none access point mode(station mode) in raspberry pi 3 (duplicate) and Switch Raspberry Pi 3 between access point and non-access point. You should finally follow one of the many suggested solutions now! If you cannot get it to work then please ask at that question and don't open always a new question. – Ingo Jan 13 at 21:30
  • sorry, i didn't know that. – ali Jan 14 at 6:21
  • @Ingo hello, by using your solution i can switch between client and AP mode. and i want to thank you for that. but i have a problem. the problem is i cant connect to the internet when i am in a client mode or when i connect to the AP with mobile phone. is it because i didn't remove the AP which i made before using your tutorial? (i couldn't leave this comment on that post so i ask it here.) – ali Jan 19 at 12:37
  • @Ingo i have two ssid other than ssid="wlan@hoeft-online.de" with the same password that i set for this ssid in the file that you said to create for wlan0. and the wifi connection icon on desktop shows the two other ssid and none of them connects to the internet. – ali Jan 19 at 13:37
0

To verify your network environment and to keep things as simple as possible I suggest to use Raspbian Stretch Lite for a check up. In a first step you should setup an access point with a wired ethernet uplink to your internet router. You can follow this Check up - Setting up a Raspberry Pi as an access point. If it is running then with this know how you can install Raspbian Stretch with desktop and recommended software from scratch from the image. This way you can improve the installation step by step to your needs.

But you should know that you cannot manage the network from the Graphical User Interface. This is because we are using systemd-networkd but supported is default dhcpcd without modifications.

Please tell me what Checkpoint fails.

  • You are using Raspbian Stretch with desktop and recommended software. You should start with Raspbian Stretch Lite. This will also fix the error editing files in a writable directory is not permitted. – Ingo Jan 30 at 12:25
  • to solve the error instead of sudo -e boot/wpa_supplicant.conf i write sudo nano boot/wpa_supplicant.conf and continue the check points. check point3 was ok but in checkpoint4 after rebooting the raspi, the "RPiNet" doesn't show on my phone and checking the eth with ip -4 addr show dev eth0 shows the ip 169.254.x.x. should i try with raspbian light now? – ali Jan 30 at 13:00
  • @ali Yes please use Raspbian Stretch Lite. Before Checkpoint 4 is no reboot. It is before Checkpoint 3. – Ingo Jan 30 at 14:06
  • i use raspbian stretch lite. when i insert the commandsudo -e boot/wpa_supplicant.conf i get error:sudo: boot/wpa_supplicant.conf: editing files in a writable directory is not permitted Hangup. should i use sudo nano. i use ubuntu16 on a virtual machine, is it related to the problem? – ali Jan 31 at 6:49
  • i try diffrent things like sudo chmod a-w boot/ sudo chmod 777 boot/ sudo chmod o+w boot/ and w !sudo nano boot/wpa_supplicant.conf but i cant change file mode it is readonly. – ali Jan 31 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.