I usually ssh to my Pi zero via usb, but for some reason its not working anymore. but after looking in the gui using hdmi, it seems like the ip on usb0 is different from what is showing on my windows computer.

I have tried (and failed):
1. Using the IP that shows up in the Pi zero as usb0 (looks like this
2. Using the IP that shows up in my windows pc (looks like this and worked before)
3. Using this "raspberrypi.mshome.net" (what shows up on my port/ip scanner and worked before) 4. Changing usb cables and using different ports
5. Reflashing the Raspbian image and configuring it for ssh via usb

Usually I could ssh via raspberrypi.mshome.net or via the ip that shows up on my computer. but for some reason now I can't connect via usb and port 22 doesn't show on the pi ip Port scanner result via usb

but connecting to the pi zero via wifi works fine
Port scanner result via wifi

I'm not sure what is wrong here, is it the cables fault? is the usb port broken? did i miss a step when configuring it?

edit: more info (i didn't know how to add it to a comment)
error when connecting via the IP that shows up on my computer
error when connecting via the IP that shows up on my computer

I hope someone could help me figure it out, and sorry for my bad English and formatting

I'm sorry if this is the wrong place to ask this.

1 Answer 1

  1. To begin with what was the error you had when you tried SSHing to the Rpi zero?
  2. Are you using any newer image of of Raspbian? The newer images have the ssh disabled by default.
  3. Did you follow all the instructions set for SSH over USB? steps in the link
  4. Try SSH with [email protected]
  • 1. I added it to the post because i didnt know how to add it to the comment 2. i used a newer version, but i created the "ssh" file and ssh works via wifi 3. yes, i edited config, cmdline and created the ssh file with no extension 4. that shows the same error... it works before, but for some reason i couldn't get it to work anymore...
    – M Isa
    Jan 15, 2019 at 9:37
  • bridging the usb connection with my wifi adapter seems to be a good workaround for now... without bridging it the ip on pi zero ifconfig is different from what shows up on the port scanner on my computer. it could have something to do with dhcp...
    – M Isa
    Jan 15, 2019 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.