0

I flashed the latest Retropie image (4.4) and it boots with a resolution of 640x480 when connected over HDMI to my 4k TV.

I used the correct Retropie image for my Pi 3. I confirmed the screen resolution using tvservice -s.

How can I get it to run at 1080p?

1 Answer 1

1

You can force a resolution by using raspi-config as follows:

  1. sudo raspi-config
  2. Select Advanced Options
  3. Select Resolution
  4. Select DMT Mode 82 1920x1080 60Hz 16:9

You can also do this manually by editing /boot/config.txt and uncommenting and changing the following lines:

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=82
hdmi_drive=2
4
  • or hdmi_group=1 hdmi_mode=16 Commented Jan 15, 2019 at 7:31
  • With hdmi_group=1 you use CEA. I experienced colour issues when using CEA on my TV, others may not.
    – Morgoth
    Commented Jan 15, 2019 at 15:52
  • fair enough - I read somewhere (though I can't find it, and it seems to be contradicted in official RPi docs) that using DMT, i.e. hdmi_group 2, will disable audio through HDMI Commented Jan 15, 2019 at 22:13
  • It might have for me, I thought it was an unrelated issue. If you follow this answer and don't have sound then do this: Why is my audio (sound) output not working?
    – Morgoth
    Commented Jan 16, 2019 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.