0

I have been using SSH remotely, enabled it though sudo raspi-config, and then a week or so later I tried to connect through PuTTy and it timed out. Checked the config and it was disabled... Any ideas on how to keep it enabled permanently?

  • 1
    Usually ssh is enabled permanently with raspi-config what you have done. You can also do it with sudo systemctl enable ssh but it doesn't make a difference. So the question should not be "how to enable ssh permanently"? instead "what situation/program could disable ssh and how to avoid this?" – Ingo Jan 16 '19 at 19:21
  • I think you are correct, I was poking around and noticed in fact the static IP address was different (changed). So of course my SSH connection wouldn't have worked, and likely my guess of the SSH server setting was incorrect.... Maybe the IP address changed when I restarted my wifi router recently? – bmfinn Jan 16 '19 at 19:39
  • A static IP address is a static IP address is a static IP address. I will never change if you do not do it by hand. So only restarting the wifi router should not change the static ip address. A dynamic changed ip address on the RasPi doesn't matter for the SSH server on the RasPi. You only have to address the RasPi. – Ingo Jan 16 '19 at 20:40
0

I set a static IP this way, it is configured to a t a dynamic IP address and when it changed I would be trying to use an outdated IP.

https://thepihut.com/blogs/raspberry-pi-tutorials/16683276-how-to-setup-a-static-ip-address-on-your-raspberry-pi

| improve this answer | |
  • Sorry, but I do not understand the answer. Do you use a dynamically set IP address as static IP address? How does it work and what is an outdated IP? Can you please edit your answer and elaborate it a bit more? – Ingo Mar 20 '19 at 9:33
0

I think you can try to find your raspberry IP, you can find it in router control and connect again. If you connect with right IP and it still timeout or refuse you can connect Pi sd card to your PC and check in boot folder have ssh file. If not you must creat file name ssh and copy it to your SD card and start your PI again. In raspbian ver 2016-11-25 SSH disabled by default. It can be enabled by creating a file with name "ssh" in boot partition You can read release notes here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.