1

Timeline of events:

  1. Installed a stable version of Raspbian, all systems work no real testing with the GPIO but HDMI and SSH work.
  2. Tested various GPIO pins for running fans and several pieces of hardware, no issues since last version.
  3. Installed touchscreens drivers from here. After this everything works fine, booting works without HDMI, with HDMI, or with the touchscreen. However, Touchscreen always defaults to even if HDMI is connected.
  4. Attempted to address the issue that the Pi always defaults to the touchscreen, but no luck. To the best of my knowledge the same functionality from the above section was all retained, and no issues appeared.
  5. I came back to working on the device one or two months later, but now the device will not boot without the touchscreen. It appears it hangs waiting for a touchscreen to get connected.

Steps attempted to fix the issue:

  1. Multiple HDMI cables tested, (no difference).
  2. Multiple power cords tested, (voltage issues on some but all work with the touchscreen).
  • Do you know what rainbow screen means? Have you checked your power supply voltage? – Dmitry Grigoryev Jan 17 at 7:51
  • Yes, i ran 2 different supplies with different voltages one from a standard phone charger that regularly gave me low voltage warnings. As well as higher voltage standardized power supply that was specifically designed for the raspberry pi. both run the raspberry pi just fine as long as i have the touch screen attached to the gpio pins. Even with that though it wont output onto the hdmi display besides the rainbow screen. – Bored915 Jan 17 at 8:59
  • How you know that your Raspberry Pi doesn't boot after disconnecting the LCD. Did you try SSH into your Raspberry Pi? – Ravi Mali Jan 21 at 17:15
  • @RaviMali Yes, doing so appears to crash the pi bios. Reconnecting typically restarts the pi. And if I am SSHed in, disconnecting the screen causes the client to say it lost connection with the pi. – Bored915 Jan 23 at 10:13
  • Have you tried booting with a new clean copy of the latest version of Raspbian? The odds seem to be that the issue is either from the driver install or the steps you tried to address defaulting to the touchscreen, but since we don't know what those are it's hard to say. Also please specify which raspberry pi you have in the question. For adding a bounty, it doesn't seem that you followed a lot of the steps from the help center to make sure you've asked a good question. – T. M. Jan 23 at 11:16
2
+50

First, try to do a clean install with this image -- the image provided by the company that manufactured the touchscreen, preloaded with the driver you need. Use Etcher, and follow the steps here, using the image above. Don't forget to "sudo apt-get update" and "sudo apt-get upgrade."

If that fails,

  1. Do a clean install of Raspbian (if you don't have any important files you want to keep, just use the same microSD card, otherwise get another)
  2. Hook the pi up to a monitor, and directly do the below without SSHing in:
  3. Upgrade and Update packages
  4. Install touchscreen driver

Possible problems could be that you have not connected a SPI interface (required per the driver's Github page), if you have a rpi3b+ you may have problems if you downloaded the driver version prior to v4.14, or that either certain package dependencies required by the driver are out of date, or the system is.

  • Your answer is good, but do you have any recommendation to rollback the drivers. I had to undertake some annoying steps to automate several of the raspberrypi features. I'd prefer not to loose all the config settings i had to adjust to get them working. (those are edits to WiFi and protocols related to it and should have 0 bearing on the issues currently) – Bored915 Jan 24 at 2:06
  • It would be difficult to remove the drivers, because when you installed them, you ran scripts which configured your system automatically under (I am assuming) root privilidges. Unfortunately, the repository here (github.com/UCTRONICS/UCTRONICS_LCD35_RPI) contains no uninstall script, so uninstalling the driver along with its kernels, as well as resetting system settings would take a looking into those scripts and checking what was changed. But attention to detail is important, as well as assessing which scripts were run. – user96931 Jan 24 at 17:34
  • Yeah, I moderately understand where it installed the drivers to. It looks like they support some form of rollback. However, they give no details and reorganize the boot location to its own folder. And without help I'm to afraid of bricking the bios and forcing a new bios. I guess I'll attempt to overwrite the boot configuration and post the results. Thanks, for looking through and confirming there were no uninstall scripts easily available. – Bored915 Jan 24 at 22:44
  • Sure, anytime :) – user96931 Jan 25 at 15:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.