1

I have a problem with the roaming option of wpa_supplicant on the raspberry pi. I tried to configure roaming and it works, but far from good.

My bgscan config was from and was the default. I used this parameters

bgscan="simple:30:-45:300"

I got it from this origin. I wasn't sure about the intervals.

Most of the time the pi just dont connect to another access point (even if its the only available). Sometimes it does connect to another access point, but the whole thing needs more than one minute, which is far too long for me. After many hours of trying I found another approach.

I edited the /etc/network/interfaces for the roaming config. Then I'm pinging a server every minute and if there is no answer, I execute

ifdown wlan0 && ifup wlan0

After these commands are executed the pi wont get an IP. If monitored things with wavemon and it appears, that the pi "sees" the network i want to connect to, but dont connect to it and get an IP. For now I have no ideas, what Im doing wrong or what other options are left.

Perhaps someone got the same problem or have an idea/solution for this problem.

Thanks in advance

  • What operating system do you use? Raspbian Stretch? Do you modify /etc/network/interfaces? – Ingo Jan 17 at 19:56
  • For roaming, how did you configure bgscan in your wpa_supplicant.conf file? – oh.dae.su Jan 20 at 19:12
  • I updated the question. I edited the etc/network/interfaces for the roaming config. And I am using Linux raspberrypi 4.14.73-v7+ #1148 SMP Mon Oct 1 16:57:50 BST 2018 armv7l GNU/Linux || Raspbian GNU/Linux 9 (stretch) – maxk Jan 22 at 7:24
  • You wrote you have modified /etc/network/interfaces. Do you respected Differences between /etc/dhcpcd.conf and /etc/network/interfaces?. – Ingo Jan 22 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.