0

I build a tv remote control using lirc on an rpi3, and it worked very fine up to this day.
Today I put a ZigBee (RaspBee) module on the first 12 GPIO pins and my output GPIO pin (17) for the remote control has to be changed.

So I changed the GPIO setting in

/etc/modules:

i2c-dev
lirc_rpi gpio_in_pin=18  gpio_out_pin=17
lirc_dev

to

i2c-dev
lirc_rpi gpio_in_pin=18  gpio_out_pin=22
lirc_dev

and

 /boot/config.txt:
  dtoverlay=lirc-rpi,gpio_in_pin=18,gpio_out_pin=17 

to

  dtoverlay=lirc-rpi,gpio_in_pin=18,gpio_out_pin=22

After rebooting the rpi, the wifi module doesn't establish a connection anymore.
If I undo the settings (back to 17), it works again.
I also tried the GPIOs 20, 21 and 24, but it's always the same result.

New Infos:
The lirc service is NOT started.
When I remove the new module, the wifi module works after reboot and I can use the other gpios

Any ideas?

Greetings,
Markus

  • ` I changed the gpio setting in /etc/modules and /boot/config.txt ` Please add the exact mods you made to these files to your question. – Dirk Jan 17 at 20:35
  • Thanks Dirk, I added a few more info. If I change the gpio_in_pin to another (only or together with the gpio_in_pin) wifi also doesn't work – Markus Jan 17 at 20:50
  • I would expect that you don't need the lirc-rpi line in /etc/modules. Try removing it completely and reboot (should be done by the dtoverlay, doing both can cause problems). – Dirk Jan 17 at 22:34
  • you're right, the line is not needed. But the problem persists. When I attach the raspbee module, wifi stops working. My theory now is: When I have the pin 17 and 18 activated for lirc, the raspbee module is deactivated. When it's activated, it's own communication interferes the wifi signal. – Markus Jan 18 at 6:07
  • I gave up on this and just using another pi, connected via cable. – Markus Jan 18 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.