Following the Tutorial - How to give your Raspberry Pi a Static IP Address my Pi 3+ doesn't appear on network. I have no HDMI display and I am trying to restore the original /etc/network/interfaces.

I already failed with Ext2Fsd Project and not able to pay for Paragon Software.

Wasn't able to OTG mount on Android with my Nexus 5 and VMware's bureaucracy and Terms&Conditions are keeping me away from it. And none of these are worked for me: raspbian - Read a file from the Raspberry Pi's SD card with Windows - Raspberry Pi Stack Exchange

And i have no any USB drive now to boot from it.

What other quick solutions i have?

  • Unrelated but, if you know what the static IP is, you could try adjusting your PC's network mask so you're on the same subnet so you can then ssh into the Pi. Commented Jan 20, 2019 at 10:42

3 Answers 3


Try booting a live CD on your laptop. That gives you a Linux system that can edit anything on any Raspberry Pi SDCard.

You can get a live CD from: https://www.raspberrypi.org/downloads/raspberry-pi-desktop/ which has the look and feel of Raspbian running on your Raspberry.

  • Yep, i needed to use live linux at the end, but CD on laptop (ThinkPad) in 2019 !? :D
    – eapo
    Commented Jan 20, 2019 at 22:37
  • I run the "live CD" in a Virtualbox. I can also boot it from a USB stick (although with my HP laptop the WiFi doesn't work). "Live CD" means "a bootable system these days, not a bootable CDROM".
    – Dougie
    Commented Jan 21, 2019 at 15:59

@Dougie's answer should allow you to edit your /etc/network/interfaces file. But since you asked for "quick solutions", there's none quicker than simply re-installing the OS on your SD card.

  • :) True, but i don't know solution to keep all the changes made in the system.
    – eapo
    Commented Jan 20, 2019 at 22:35

As @Dougie recommended, i was using Live linux to roll back the /etc/network/interfaces file on the Pi's SD:

  1. because i had no USB stick, or not even a CD/CD-rom I was using an USB SD reader and old 2Gb SD card
  2. with the amazing LinuxLive USB Creator and
  3. PuppyLinux: Tahrpup 6.0 CE
  4. using the following commands:
    • blkid - command-line utility to locate/print block device attributes
    • mount - mount a filesystem

enter image description here

And my Pi is up and running! :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.