I have a TP-Link TL-WN722N and i want to connect it to my Raspberry Pi Zero W. I saw somewhere that it works fine on a non-zero pi, but it doesn't show up in my iwconfig or ifconfig...
it does show up in lsusb as:

Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

Which made me think its a driver/firmware issue. so i tried installing "firmware-atheros" using "sudo apt-get install firmware-atheros"
but this is the result:

firmware-atheros is already the newest version (1:20161130-3+rpt4).

here is the ifconfig result:

pi@raspberrypi:~ $ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 17  bytes 1004 (1004.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 17  bytes 1004 (1004.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether be:63:bc:43:60:5c  txqueuelen 1000  (Ethernet)
        RX packets 239  bytes 22752 (22.2 KiB)
        RX errors 0  dropped 6  overruns 0  frame 0
        TX packets 33  bytes 6596 (6.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::93b2:2794:f7d4:78a1  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:b3:29:bb  txqueuelen 1000  (Ethernet)
        RX packets 136444  bytes 7310610 (6.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 135677  bytes 11947992 (11.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

That is all i have tried, because i couldn't find someone else with the same issue...


Do you use Raspbian? It seems interface usb0 is from the USB/wifi dongle so everything may be right. Curious is that usb0 has transmitted and received packets without an ip address. Maybe it tries to get an ip address from a DHCP server but there is no one? Verify that usb0 is from the USB/wifi dongle. Unplug the dongle and look if the interface is still there.

If not then you should try to associate to a wifi network with usb0 by configuring wpa_supplicant.

  • I think usb0 is there because I was ssh-ing using the USB port... In kali Linux (also on the pi zero) the tplink adapter show up in lsusb but doesn't show on ifconfig, also there is no usb0 interface on Kali. I think it's a driver's thing, do you know where I could get the drivers for this? – M Isa Jan 21 '19 at 23:45
  • @MIsa Do you use Kali linux? If so you should have mentioned it in your question because it's an important information. I have no idea where to get drivers. You can try a default Raspbian Stretch installation. – Ingo Jan 21 '19 at 23:54
  • I used raspbian before and it didn't work, and then I tried Kali and it still didn't work – M Isa Jan 21 '19 at 23:55
  • So I tried both and it didn't work... – M Isa Jan 21 '19 at 23:56

Removing the modification on the boot partition that I have to ssh via USB fixed it, now it works on raspbian and also Kali linux

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Mar 2 '20 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.