1

I'm trying to hook up 2 Adafruit Quad Alphanumeric displays to my Rasberry Pi 3 B+.

From what I understand, all I need to do is hookup the displays in series to the SDA SCL outs, and the I2C chip is able to dynamically assign addresses to the devices I hookup.

No matter what I tried, when I hooked up my devices, and I run sudo i2cdetect -y 1 they would both be shown as assigned to address 0x70. If I hooked up the displays independently, they would both work, and be assigned address 0x70. But when I attached 2, they would both still be assigned 0x70. I was still able to send text commands to them either independently or both wired up, but they would both show the same text.

Is there a way to debug the I2C chip on the RaspberryPi to confirm it is working correctly?

I have tried reinstalling the OS twice.

I’ve attached a diagram of how I have wired up my displays in case I got it wrong somehow.

Diagram of 2 Adafruit Quad Alhpanumeric Displays in Series Connected To Raspberry Pi.

  • 1
    look for the address selection solder points A0 A1 and A2 - look at about page 61 in the adafruit PDF for these things – Jaromanda X Jan 21 '19 at 2:44
5

The Pi does NOT assign addresses. They are set by the device.

Some devices have configurable addresses.

|improve this answer|||||
  • Thanks for the clarification. Will do some digging and try answer my own question. – Christos Hrousis Jan 21 '19 at 1:59
2

If you want to have two different addresses you need to configure them with jumpers :

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.