0

I connected two PS3 Eye cameras to my raspberry pi. Separately, cameras work fine. I can record the video in any supported resolution and frame rate. Unfortunately when I tried to record video from this cameras simultaneously, I ran into a problem. With resolution 640x480 cameras can work just a couple of seconds. Then ffmpeg throws an error and one of the cameras stops recording.

Commands:

ffmpeg -f v4l2 -r 30 -s 640x480 -an -sn -i /dev/video0 -f avi cam1.avi
ffmpeg -f v4l2 -r 30 -s 640x480 -an -sn -i /dev/video1 -f avi cam2.avi

Error:

Dequeued v4l2 buffer contains 609076 bytes, but 614400 were expected. Flags: 
0x00002001.
/dev/video0: Invalid data found when processing input
enter code here

Also cameras can recording the video simultaneously with the lower resolution. (320x240 in any frame rate without errors).

I tried to stream video from cameras through gstreamer: 1) With resolution 640x480 when I tried to stream simultaneously, the stream stopped. 2) With resolution 320x240 all works fine.

Is it hardware or software problem? Maybe not enough power? How to solve it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.