0

I have just created a SSH connection between my Raspberry Pi 3 b+ and my computer using WiFi. I have downloaded Eclipse and the PyDev and RSE plugins so I can use Eclipse as IDE for my Python scriptss that I need to run on my Rasp Pi.

Everything works fine, I can create the script in Eclipse and run it in the Rasp Pi using the ssh console.

I want to use the Remote Debugger from Eclipse to be able to debug my Python codes from my Rasp Pi. So I have installed pydevd on my Rasp Pi sudo pip3 install pydevd, started the Debug Server (port: 5678) and write this piece of code on my script so it can be debugged on the server.

import sys
sys.path.append(r'/usr/local/lib/python3.5/dist-packages')
import pydevd;
pydevd.settrace('192.168.7.196',port=5678)

When I run the script in my SSH shell it appears this error:

pi@raspberrypi:~/RaspIrradiationproj $ python3 test.py
Could not connect to 192.168.7.196: 5678
Traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/_pydevd_bundle/pydevd_comm.py", line 549, in start_client
    s.connect((host, port))
socket.timeout: timed out
Traceback (most recent call last):
  File "test.py", line 6, in <module>
    pydevd.settrace('192.168.7.196',port=5678)
  File "/usr/local/lib/python3.5/dist-packages/pydevd.py", line 1314, in settrace
    stop_at_frame,
  File "/usr/local/lib/python3.5/dist-packages/pydevd.py", line 1363, in _locked_settrace
    debugger.connect(host, port)  # Note: connect can raise error.
  File "/usr/local/lib/python3.5/dist-packages/pydevd.py", line 356, in connect
    s = start_client(host, port)
  File "/usr/local/lib/python3.5/dist-packages/_pydevd_bundle/pydevd_comm.py", line 549, in start_client
    s.connect((host, port))
socket.timeout: timed out

The only thing I can think off is that mybe the IP address of my host computer is wrong, but using ipconfig in the windows cmd I obtain:

C:\Users\danie>ipconfig

Configuración IP de Windows


Adaptador de Ethernet Ethernet 2:

   Estado de los medios. . . . . . . . . . . : medios desconectados
   Sufijo DNS específico para la conexión. . :

Adaptador de LAN inalámbrica Conexión de área local* 1:

   Estado de los medios. . . . . . . . . . . : medios desconectados
   Sufijo DNS específico para la conexión. . :

Adaptador de LAN inalámbrica Conexión de área local* 3:

   Estado de los medios. . . . . . . . . . . : medios desconectados
   Sufijo DNS específico para la conexión. . :

Adaptador de LAN inalámbrica Wi-Fi:

   Sufijo DNS específico para la conexión. . :
   Vínculo: dirección IPv6 local. . . : fe80::55a2:974c:7067:886f%17
   Dirección IPv4. . . . . . . . . . . . . . : 192.168.7.196
   Máscara de subred . . . . . . . . . . . . : 255.255.254.0
   Puerta de enlace predeterminada . . . . . : 192.168.6.1

Adaptador de Ethernet Conexión de red Bluetooth:

   Estado de los medios. . . . . . . . . . . : medios desconectados
   Sufijo DNS específico para la conexión. . :
0

After looking for an answer I came up with the solution of disabling the firewall and it worked. So i'ts a matter of the access that are permited in the firewall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.