0

I got a Raspberry Pi 3 B+ over Christmas which came with a breadboard (i.e. I'm new to all of this). I recently bought a Maxbotix HRLV-EZ4 ultrasonic sensor.

I am using the Canakit GPIO Breakout Board

My wiring is as follows:

I'm following these wiring guidelines from Maxbotix' own instructions

I've added the following to the end of my /boot/config.txt:

enable_uart=1
dtoverlay=pi3-disable-bt
dtoverlay=pi3-miniuart-bt

I followed MaxBotix' instructions and installed minicom. When I run the command minicom -b 9600 -o -D /dev/ttyS0 I get no results, like what's shown on the instructions page.

I've used the Python script that MaxBotix provided as-is. I've also run that script replacing serialDevice's value with dev/ttyS0 in appropriate places.

When I run the python script, I get the error Expected serial data not received.

While I'm comfortable with Linux and Python, I'm super new to Raspberry Pi and GPIO / Hardware. I'm about 70% certain that the issue isn't with the code. I'm more convinced the issue is with either wiring or some other setup I don't know about.

What could I be doing wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.