1

I had some problems getting this installed so I did it again on a clean wheezy latest distro. The server ran pretty fast locally with an old HTML website then when I got Wordpress installed it wouldn't work but no matter , I installed Wordpress in another /var/www/word folder. After installing Wordpress I noticed it was my local ip in the sites URL settings. I'd known that my ip had to be used in numeric form and yes forward my http port to that specific pi but its running so slow and can't login , loses connection. I ran top and there is very little running at all. I notice also that it won't load on my Mac at all but will on my iPhone. I even went in and cut the gpu mem to 16mb. It ran well before.. I got mypi.no-ip.biz to follow my ip and for a web name , which again I doubt that service has anything running high cpu. Would netatalk or local file server software have caused this ? Should I be using dedicated server software ? It ran fast locally...

  • 2
    Can you please edit this question laying out concisely what steps you've taken and what you've tried. In this format it's pretty difficult to read and understand. – Jivings Aug 31 '13 at 11:55
  • 3
    Sort of incoherent, but based on the clue in the last line ("it ran fast locally...") I'm guessing this is a duplicate of raspberrypi.stackexchange.com/questions/9130/… -- the problem is that you are trying to run a server from inside your home with a residential ISP account. That will be slow no matter what kind of computer you use; ISP's rate limit uploads much more than downloads and when you download something from a server, the server has to upload it. – goldilocks Aug 31 '13 at 13:35
1

I don't know how MySQL is configured by default in your distribution, but you may try to reduce MySQL memory settings.

You can do it in my.cnf file, located somewhere in etc (probably /etc/mysql).

There should be also mysmall.cnf sample config file, you can replace your my.cnf with copy of mysmall.cnf.

Please make backup of /etc/mysql before you do something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.