1

Is it possible to install Kali tools on Raspbian? I have tried Katoolin but I keep getting a segmentation fault error when fixing the dependencies and getting stuck in a loop where "it is not going to be installed" because I don't know how to fix the error...

Has anyone tried doing this and have it work?

The errors seems to have something to do with libwebkit2gtk-4 0-37 (and it's dependencies) and that segmentation fault when the apt is doing something with libc-dev (or something similar, I forgot and my ssh client doesn't have that stored on the history any more).

Sorry for the bad formatting, it's midnight and I started trying to figure this out at 7pm... And I have been re-flashing my microsd card every time the error comes up which took a long time...

1

Yes, it's easy to install Kali on Raspbian. Follow the guide here or do the below:

  1. If you don't have Git run sudo apt-get install git
  2. Become root, run sudo -i or su then enter password
  3. Git clone, run git clone https://github.com/LionSec/katoolin.git and cp katoolin/katoolin.py /usr/bin/katoolin
  4. Make katoolin executable: chmod +x /usr/bin/katoolin
  5. To run Katoolin, sudo katoolin

Note that it is imperative that you remove all Kali Linux tools before you update or upgrade Raspbian.

  • 2
    Wouldn't it be better to install to /usr/local/bin instead? This way you have no potential conflicts with anything the distro is prone to install or update, and stuff in /usr/local/bin has precedence in $PATH. – goldilocks Jan 23 at 17:44
  • Perhaps, but their page on Github reccomends /usr/bin/katoolin, so the paths in their python scripts might be absolute. – user96931 Jan 23 at 17:48
  • 1
    I already tried that and it wouldn't work, because there is packages with no installation candidate, and even after removing those packages there was dependencies issues with libwebkit2gtk and another package called enchant (or maybe libenchant, it has the word enchant somewhere). I already know how to use katoolin because I have used it multiple time on x86 Ubuntu. BTW, I'm on a pi zero. – M Isa Jan 23 at 23:16
  • Surely it would be easier to use the official Kali build for a Raspberry docs.kali.org/kali-on-arm/install-kali-linux-arm-raspberry-pi – Dougie Jan 24 at 7:14
  • I actually tried installing Kali directly but it didn't come with a desktop and installing a desktop results in a black empty screen... – M Isa Jan 24 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.