0

I've added a line to fstab to mount external drive.

proc            /proc           proc    defaults          0       0
PARTUUID=5c32fc0d-01  /boot           vfat    defaults          0       2
PARTUUID=5c32fc0d-02  /               ext4    defaults,noatime  0       1
UUID=C632D59E32D593B1 /plex ntfs-3g uid=1000,gid=1000,nofail,umask=007,user 0 0

Drive mounts fine but I'm trying to setup a Samba share on the same folder.

smb.conf extract

[plex]
path = /plex
writeable = yes
guest only = yes
public = yes

I can see the share from win 10 but if I access it windows gives me an error saying "you do not have permission to access \192.168.0.36\plex"

If I setup a share on another folder thats not a mounted directory win 10 has no trouble seeing the contents.

If I run ls-l on the folder I can see that the permissions are set thus

drwxrwx---   1 pi   pi   20480 Jan 24 17:52 plex

I've tried

sudo chown 777 /plex

but the permissions stay the same.

Any help appreciated.

  • chown 777 - you've set the userid to 777, and haven't touched the permissions ... did you mean chmod 777? – Jaromanda X Jan 25 at 22:47
  • Doh.... Keep getting caught out with permissions. I'll try it. – Nelodemus Jan 25 at 23:27
1

Finally sorted it. Found a great article on the plex website about mounting ntfs drives. Add the option "permissions" to the fstab and it let me change the permissions once mounted, that let the samba share work.

  • I do not understand how to set an option permissions. Can you please explain a bit more in detail, maybe with an example? Do you have a link to the great article? – Ingo Jan 26 at 12:17
  • Here you go. support.plex.tv/articles/… – Nelodemus Jan 28 at 9:30
0

Try changing your fstab to UUID=C632D59E32D593B1 /plex ntfs defaults 0 2 when I've been setting up smb drives in the past I had similar issues and it's been a case of the drive not mounting with the correct permissions on boot. The above ntfs defaults 0 2 is currently working for me using a pi as a nas. Hope that helps. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.