1

I just bought a Raspberry PI 3 B+ some weeks ago, and I decided to install Alpine Linux due to it uses OpenRC and one friend of me recommended it to me.

I have installed it only as diskless mode, because I want to connect it to my WiFi and then finish the installation comfortably. I have to say that I have only a basic understanding on how WiFi networks works, and just tried to connect via command line one time before.

Well, I installed wpa_supplicant and wireless-network tools and then I tried this:

ip link set wlan0 up
iwlist wlan0 scanning

And this is when the first error appears:

wlan0    Interface doesn't support scanning : Interrupted system call

So I do:

iw wlan0 link

But it returns me:

Not connected.

Well, let's say we can ignore this (I guess not), my /etc/wpa_supplicant/wpa_supplicant.conf file goes like this:

network={
    ssid="MY_CORRECT_WIFI_NAME"
    psk="12345678"
    key_mgmt=WPA-PSK
}

But when I run:

wpa_supplicant -B -D wext -i wlan0 -C /etc/wpa_supplicant.conf

It doesn't work (again, probably because of that not connected shown before).

What should I do?

My wlan0 driver is brcmfmac.

Please tell me if you need me to show more information.

Thanks for reading.

  • I'm afraid there is not much knowledge here about Alpine Linux. Most of us use Raspbian Stretch, the official operating system from the Foundation for the Raspberry Pi. So I suggest to use this. Or maybe ask your friend? – Ingo Jan 26 at 20:23
  • @Ingo Getting Raspbian to use musl-libc would require much more work than installing Alpine. – Dmitry Grigoryev Jul 12 at 7:14
1

You need to install the firmware for this to work.

On my Raspberry Pi 3B+, I placed these on the SD card in

/firmware/brcm/

https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm

  • brcmfmac43455-sdio.txt
  • brcmfmac43455-sdio.bin
  • brcmfmac43455-sdio.clm_blob

Then it worked as expected. Whew, it took a lot of surfing to figure that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.