0

NOTE: Although this seems to be a hostapd problem, however, this problem exists on RP only and that's why I'm posting it here. So please do not downvote because it seems like a hostapd problem and not RP.

I'm trying to setup a WPA2 Enterprise hotspot using a Raspberry Pi 3B+. I successfully built and installed Freeradius 3.0.17 on the RP, and tested it with radtest. I also managed to setup an access point using hostapd for a WPA-PSK network, as well as WPA-EAP but only for wpa1 (wpa=1 in hostapd config file). This is the configuration that works for wpa1:

interface=wlan0
driver=nl80211
ssid=whatever
hw_mode=g
channel=7
ieee8021x=1
auth_algs=1
eap_server=0
eapol_key_index_workaround=0

wpa=1
wpa_key_mgmt=WPA-EAP
rsn_pairwise=TKIP
wpa_group_rekey=300
wpa_gmk_rekey=640
auth_server_addr=127.0.0.1
auth_server_port=1812
auth_server_shared_secret=testing123
acct_server_addr=127.0.0.1
acct_server_port=1813
acct_server_shared_secret=testing123

This also works when I set the rsn_pairwise to CCMP. But it doesn't work anymore when I set wpa=2. The log for hostapd is available here.

I will highly appreciate if someone could help me with this.

EDIT:

Here's the documentation description for wpa field in hostapd configuration:

# This field is a bit field that can be used to enable WPA (IEEE 802.11i/D3.0)
# and/or WPA2 (full IEEE 802.11i/RSN):
# bit0 = WPA
# bit1 = IEEE 802.11i/RSN (WPA2) (dot11RSNAEnabled)
# Note that WPA3 is also configured with bit1 since it uses RSN just like WPA2.
# In other words, for WPA3, wpa=2 is used the configuration (and
# wpa_key_mgmt=SAE for WPA3-Personal instead of wpa_key_mgmt=WPA-PSK).
#wpa=2
1

This issue comes from kernel and hostapd service in raspbian jessie. In your logs in 385 line you can notice that 4-way handshake has never ending and it stoped on third step. It could be exception in pseudorandom generator.

You can use external WiFi dongle as a workaround now, or wait for a patch.

  • 1
    Thank you I actually ended up doing the same thing on a laptop instead of RP – Kennet Celeste Feb 5 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.