1

When I set the Pi (Zero) up with the required 640x480 60Hz mode in config.txt the SV-3 reports no signal.

But if I plug a VGA Acer monitor in to the Pi and then unplug it, plugging in the SV-3 works!

I am using a standard micro HDMI->HDMI converter with a HDMI->VGA converter (Branded Pi-Hut)

In the config.txt I have tried various combinations of

hdmi_safe=1

hdmi_ignore_edid=0xa5000080

hdmi_group=1    CEA
hdmi_mode=1     VGA 640x480
hdmi_mode=2     480p 
hdmi_mode=3     480p H

hdmi_group=2    DMT
hdmi_mode=4     640x480 60 Hz

Then I tried plugging in the Acer monitor and running

/opt/vc/bin/tvservice -d edid.dat 

putting edid.dat into /boot and setting the

hdmi_edid_file=1

I also compared the edid.dat when just the SV-3 was plugged in vs the Acer monitor (links to files at the end)

Running

/opt/vc/bin/tvservice -s

for either VGA device gives

state 0x12000a [HDMI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive

and running X and then randr from a VT for both devices gives

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 576 x 416, current 576 x 416, maximum 576 x 416
default connected 576x416+0+0 0mm x 0mm
   576x416        0.00* 

get-edid always reports nothing on the i2c bus

So I know it is the Pi doing something to the HDMI output when I plug in the Acer monitor that makes the SV-3 work when it is plugged in afterwards. But it does not seem to be the edid so I am at a complete loss as to what to try now.

This is a strange setup so I appreciate any answers or ideas.

edid for the Acer monitor text file edid for the SV-3 text file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.