2

My RPi 3 says no bluetooth adapter is detected and therefore won't let me connect to a device. The BT logo is greyed out instead of blue and running sudo systemctl status bluetooth it says the service is inactive (dead). I am also unable to start hciuart.service, which I believe is a part of it. Please help.

  • There's some other people who have had the same issue - have you tried any of the fixes mentioned? – Jaromanda X Jan 29 at 1:10
  • 1
    Possible duplicate of WiFi and Bluetooth is not found in raspberry pi 3 model b – Ingo Jan 29 at 1:39
  • @JaromandaX I did--nothing worked. I might just give up and spend $35 on a new one... – Master Chief Jan 29 at 1:40
  • so, you've even tried a brand new fresh install? cheaper than a new Pi :p – Jaromanda X Jan 29 at 1:41
  • @JaromandaX multiple times--I've even tried other OSes. I could prob use a model B+ anyway, but I might wait to see if they release the 4 on schedule in February. – Master Chief Jan 29 at 1:50
3

If you get no BT on a latest unmodified Raspbian image, and you're confident you flashed your SD card correctly, send your RPi back to the shop you got it from and get a new one.

  • It was waaaay past the warranty and I lost the box and had ordered off some Amazon seller a long time ago. Luckily the 3 B+ wasn't that expensive. I guess I just blew out the BT adapter with my garbage power supply thing I was using. – Master Chief Apr 19 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.