1

My RPi 3 says no bluetooth adapter is detected and therefore won't let me connect to a device. The BT logo is greyed out instead of blue and running sudo systemctl status bluetooth it says the service is inactive (dead). I am also unable to start hciuart.service, which I believe is a part of it. Please help.

  • There's some other people who have had the same issue - have you tried any of the fixes mentioned? – Jaromanda X Jan 29 at 1:10
  • 1
    Possible duplicate of WiFi and Bluetooth is not found in raspberry pi 3 model b – Ingo Jan 29 at 1:39
  • @JaromandaX I did--nothing worked. I might just give up and spend $35 on a new one... – Master Chief Jan 29 at 1:40
  • so, you've even tried a brand new fresh install? cheaper than a new Pi :p – Jaromanda X Jan 29 at 1:41
  • @JaromandaX multiple times--I've even tried other OSes. I could prob use a model B+ anyway, but I might wait to see if they release the 4 on schedule in February. – Master Chief Jan 29 at 1:50
3

If you get no BT on a latest unmodified Raspbian image, and you're confident you flashed your SD card correctly, send your RPi back to the shop you got it from and get a new one.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.