0

I'm running a Node server on port :3000 and want to access it from other devices using Pi's wlan0 address.

wlan0: 169.254.36.22

  • Accessing from Macbook works
  • Accessing from iPhone works
  • Accessing from Android doesn't work (connection timeout)

eth0: 192.168.132 - Accessing from all 3 devices works good.

What could be the potential cause of this problem?

I lost every hope in Android devices. They don't support zeroconf (raspberrypi.local) out of the box, and now this weird problem.

  • I'm surprised anything can connect to a 169.254.x.x address - but I guess zeroconf makes that possible - read up on what 169.254.x.x addresses are ... then give you wlan a useful IP address instead – Jaromanda X Jan 29 at 22:20
  • @JaromandaX That's what confused me. I'm familiar with 169 but it was unclear why iPhone and Mac would connect and Android no – Dino Jan 29 at 22:22
  • @Dino is Android connected on the same access point with the other 2 computers? – GramThanos Jan 29 at 22:26
  • @GramThanos yes all 3 of them are on same AP – Dino Jan 29 at 23:13
0

The answer is already given in your question. Android does not support link-local ip addresses out of the box. It needs a DHCP server. If you are interested for details I have just verified this in Check up - Setting up a Raspberry Pi as an access point. On Checkpoint 4 you will see the access point (RPiNet) in the list of access points on your mobile phone but you cannot connect to it yet. Only if you configure a DHCP server to the access point interface (/etc/systemd/network/08-wlan0.network) the mobile phone will connect.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.