0

This question is an exact duplicate of:

My nodejs app is using pigpio. It keeps getting error because port pigpiod is listen on port 8888 already. I can kill -9 the process but when I restart pi port 8888 is jammed up again. How do i solve this issue? Should i remove the npm pigpio libary and reinstall?

marked as duplicate by Milliways, Ghanima Feb 13 at 17:13

This question was marked as an exact duplicate of an existing question.

0

You can specify port by running pigpiod daemon with parameter -p <portnumber>

Example: If you want to run pigpiod on port 1234

pigpiod -p 1234

  • there should be config file in /etc/... but I have no Raspberry with me so I can't verify it. – Koxo Jan 30 at 12:32
  • Thanks; Ultimately I need to completely reinstall npm and pm2. Every thing works great now. – z Eyeland Feb 4 at 21:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.